$re = '/\[CDATA\[([^\]]+)(?![\s\S]*\[CDATA)/';
$str = '<?xml version=\'1.0\' encoding=\'UTF-8\'?>
<partial-response><changes><update id="layout:layoutLeft:treeForm:riverTree">
<![CDATA[<li id="layout:layoutLeft:treeForm:flussgebieteBaum:0_0_0" data-rowkey="0_0_0"
class="ui-treenode ui-treenode-parent river default" role="treeitem">
<span class="ui-treenode-content ui-tree-selectable" aria-expanded="false" aria-selected="false">
<span class="ui-tree-toggler ui-icon ui-icon-triangle-1-e"></span><span></span>
<span class="ui-treenode-label ui-corner-all"><span title="W">W</span></span>
<span class="hwims-markingSpan"></span></span><ul class="ui-treenode-children" style="display:none">
</ul></li>]]></update><update id="javax.faces.ViewState">
<![CDATA[5518082394550102028:7288540440023391844]]></update></changes></partial-response>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);