import Foundation
let pattern = #"\[CDATA\[([^\]]+)(?![\s\S]*\[CDATA)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<?xml version='1.0' encoding='UTF-8'?>
<partial-response><changes><update id="layout:layoutLeft:treeForm:riverTree">
<![CDATA[<li id="layout:layoutLeft:treeForm:flussgebieteBaum:0_0_0" data-rowkey="0_0_0"
class="ui-treenode ui-treenode-parent river default" role="treeitem">
<span class="ui-treenode-content ui-tree-selectable" aria-expanded="false" aria-selected="false">
<span class="ui-tree-toggler ui-icon ui-icon-triangle-1-e"></span><span></span>
<span class="ui-treenode-label ui-corner-all"><span title="W">W</span></span>
<span class="hwims-markingSpan"></span></span><ul class="ui-treenode-children" style="display:none">
</ul></li>]]></update><update id="javax.faces.ViewState">
<![CDATA[5518082394550102028:7288540440023391844]]></update></changes></partial-response>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)