using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([0-1][0-9]|[2][0-3]):([0-5][0-9])|((?<!\d)[1]*[0-9]|[2][0-3]):([0-5][0-9])$";
string input = @"23:59";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}