$re = '/^([0-1][0-9]|[2][0-3]):([0-5][0-9])|((?<!\d)[1]*[0-9]|[2][0-3]):([0-5][0-9])$/m';
$str = '23:59';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);