package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*\D)\d+-\d+`)
var str = `path = D:/me/vol101/Prod/cent/2019_04_23_01/image/AVEN_000_3400_img_pic_p1001-1010/pxy/AVEN_000_3400_img-mp4_to_MOV_v1001-1010.mov`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}