re = /(.*\D)\d+-\d+/m
str = 'path = D:/me/vol101/Prod/cent/2019_04_23_01/image/AVEN_000_3400_img_pic_p1001-1010/pxy/AVEN_000_3400_img-mp4_to_MOV_v1001-1010.mov'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end