using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d*)((\/)\d*)? ([^ ]*) (Alley|Approach|Arcade|Avenue|Boardwalk|Boulevard|Break|Bypass|Chase|Circuit|Close|Concourse|Court|Crescent|Crest|Drive|Entrance|Esplanade|Firetrail|Freeway|Glade|Grange|Grove|Highway|Lane|Loop|Mall|Mews|Parade|Parkway|Passage|Path|Place|Plaza|Promenade|Quays|Ramp|Retreat|Ridge|Rise|Road|Square|Steps|Street|Subway|Terrace|Track|Trail|View|Vista|Walk|Way|Wharf)";
string input = @"1/7 Kieller Avenue";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}