const regex = /^(?!.*(the|and|or|a|given|some|that|this|then|than))(?!.*[ ]{2})(?!.*[']{2})(?!.*[-]{2})(?:[a-zA-Z0-9 \:\p{L}'-]{1,64}$)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*(the|and|or|a|given|some|that|this|then|than))(?!.*[ ]{2})(?!.*[\']{2})(?!.*[-]{2})(?:[a-zA-Z0-9 \\:\\p{L}\'-]{1,64}$)$', 'gm')
const str = `a foo
bar
aaa --foofoo
123456789012345678901234567890123456789012345678901234:
given
in the`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}