$re = '/^(?!.*(the|and|or|a|given|some|that|this|then|than))(?!.*[ ]{2})(?!.*[\']{2})(?!.*[-]{2})(?:[a-zA-Z0-9 \:\p{L}\'-]{1,64}$)$/m';
$str = 'a foo
bar
aaa --foofoo
123456789012345678901234567890123456789012345678901234:
given
in the';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);