package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\p{L}0-9 -]`)
var str = `abc // t?% ?? ttt ,. y Ä Ö Ü ä, ö !`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}