$re = '/[^\p{L}0-9 -]/m';
$str = 'abc // t?% ?? ttt ,. y Ä Ö Ü ä, ö !';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);