import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.*)testhack(?:[[:alnum:][:blank:]\\\\\\/\\._-]*)(?<!\\.git|\\.gitignore)$";
final String string = "/home/kwaadpepper/testhack\n"
+ "/home/kwaadpepper/testhack/TwitterReport\n"
+ "/home/kwaadpepper/testhack/test\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.git\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.gitignore\n"
+ "/home/kwaadpepper/testhack/TwitterReport/LICENSE\n"
+ "/home/kwaadpepper/testhack/TwitterReport/README.md\n"
+ "/home/kwaadpepper/testhack/TwitterReport/log_Error.txt\n"
+ "/home/kwaadpepper/testhack/TwitterReport/log_reported_2015111731047.txt\n"
+ "/home/kwaadpepper/testhack/TwitterReport/log_reported_2015111761057.txt\n"
+ "/home/kwaadpepper/testhack/TwitterReport/log_reported_2015111762323.txt\n"
+ "/home/kwaadpepper/testhack/TwitterReport/log_reported_201511176245.txt\n"
+ "/home/kwaadpepper/testhack/TwitterReport/log_suspended.txt\n"
+ "/home/kwaadpepper/testhack/TwitterReport/twitterReport.py\n"
+ "/home/kwaadpepper/testhack/TwitterReport/twitter_accounts.txt\n"
+ "/home/kwaadpepper/testhack/TwitterReport/twitter_accounts2.txt\n"
+ "/home/kwaadpepper/testhack/TwitterReport/twitter_accounts2.txt.save\n"
+ "/home/kwaadpepper/testhack/TwitterReport/twitter_accounts3.txt\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.git/HEAD\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.git/branches\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.git/config\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.git/hooks/pre-applypatch.sample\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.git/hooks/pre-commit.sample\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.git/hooks/pre-push.sample\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.git/hooks/pre-rebase.sample\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.git/hooks/prepare-commit-msg.sample\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.git/hooks/update.sample\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.git/info/exclude\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.git/objects/21\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.git/objects/4d\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.git/objects/59\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.git/objects/69\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.git/objects/70\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.git/objects/f9/00faba8624d5cbfee6032ad6266c6722b19457\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.git/refs/heads\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.git/refs/remotes\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.git/refs/tags\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.git/refs/heads/master\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.git/refs/remotes/origin\n"
+ "/home/kwaadpepper/testhack/TwitterReport/.git/refs/remotes/origin/HEAD";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}