using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{1,3}\.?)+,\d{2}";
string input = @"0,10
1,00
10,00
100,00
1.000,00
10.000,00
100.000,00
1.000.000,00
00.001..00,00
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}