$re = '/(\d{1,3}\.?)+,\d{2}/m';
$str = '0,10
1,00
10,00
100,00
1.000,00
10.000,00
100.000,00
1.000.000,00
00.001..00,00
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);