$re = '/(?<!\d|-)\d{6,}(?=\D)(?![.@])|\d{6,}(?=$)/m';
$str = '010-12345678 => invalid
12345678 => valid';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);