re = /(?<!\d|-)\d{6,}(?=\D)(?![.@])|\d{6,}(?=$)/m
str = '010-12345678 => invalid
12345678 => valid'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end