re = /\sdhcpd(\:\s|\[\d+\]\:\s)/m
str = 'Jul 18 09:12:43 dhcp-server-name dhcpd[1569]: DHCPACK on ip-address to 00:00:00:00:00:00 (modem-type) via ip-address
Jul 18 09:12:43 dhcp-server-name dhcpd: DHCPACK on ip-address to 00:00:00:00:00:00 (modem-type) via ip-address'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end