// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\sdhcpd(\:\s|\[\d+\]\:\s)").unwrap();
let string = "Jul 18 09:12:43 dhcp-server-name dhcpd[1569]: DHCPACK on ip-address to 00:00:00:00:00:00 (modem-type) via ip-address
Jul 18 09:12:43 dhcp-server-name dhcpd: DHCPACK on ip-address to 00:00:00:00:00:00 (modem-type) via ip-address";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}