using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\W_]+";
string substitution = @" ";
string input = @"The___quick , brown
fox jumps @ over
the lazy dog";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}