const regex = /[\W_]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\W_]+', 'g')
const str = `The___quick , brown
fox jumps @ over
the lazy dog`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);