import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\n|\\n$";
final String string = "\n"
+ "import regex as re\n"
+ "from colorama import Fore, Back\n\n"
+ "def red(s):\n"
+ " return Back.RED + s + Back.RESET\n\n"
+ "with open('/tmp/1.py', 'r') as f:\n"
+ " data = f.read()\n\n"
+ "print(\n"
+ " re.sub(r'(^\\n|\\n$)', red(r'\\1'), data)\n"
+ ")\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}