$re = '/^\n|\n$/';
$str = '
import regex as re
from colorama import Fore, Back
def red(s):
return Back.RED + s + Back.RESET
with open(\'/tmp/1.py\', \'r\') as f:
data = f.read()
print(
re.sub(r\'(^\\n|\\n$)\', red(r\'\\1\'), data)
)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);