package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{4}[A-Z]?$`)
var str = `1234
1234A
1234a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}