$re = '/^\d{4}[A-Z]?$/m';
$str = '1234
1234A
1234a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);