package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(((<|>)=?)|(!=))\s?\d+(\.\d+)?$`)
var str = `>9
<=10
>= 10
!=20.0
>>2
<
=2$%$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}