$re = '/^(((<|>)=?)|(!=))\s?\d+(\.\d+)?$/m';
$str = '>9
<=10
>= 10
!=20.0
>>2
<
=2$%$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);