#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d"
Local $sString = " Art. 3." & @CRLF & _
"1. Grupa producentów rolnych, zwana dalej "grupą", prowadzi działalność jako" & @CRLF & _
" przedsiębiorca mający osobowość prawną pod warunkiem, że:" & @CRLF & _
" 1) została utworzona przez producentów jednego produktu rolnego, zwanego" & @CRLF & _
" dalej "produktem", lub grupy produktów w celach określonych w" & @CRLF & _
" art. 2," & @CRLF & _
" 2) działa na podstawie statutu lub umowy, zwanych dalej "aktem" & @CRLF & _
" założyielskim", spełniających wymagania określone w art. 4," & @CRLF & _
" 3) składa się z członków, udziałowców lub akcjonariuszy, zwanych dalej" & @CRLF & _
" "członkami grupy", z których żaden nie może mieć więcej niż 20% głosów na" & @CRLF & _
" walnym zgromadzeniu lub zgromadzeniu wspólników," & @CRLF & _
" 4) osiąga co najmniej:" & @CRLF & _
" - w pierwszym roku działalności - 51%," & @CRLF & _
" - w drugim roku działalności - 60%," & @CRLF & _
" - w trzecim roku i następnych latach działalności - 75%," & @CRLF & _
" udokumentowanych przychodów ze sprzedaży produktów grupy wytworzonych w" & @CRLF & _
" gospodarstwach jej członków," & @CRLF & _
" 5) określi obowiązujące członków grupy zasady produkcji, w tym dotyczące" & @CRLF & _
" jakości i ilości produktów lub grup produktów oraz sposoby przygotowania" & @CRLF & _
" produktów do sprzedaży." & @CRLF & _
"2. Warunek, o którym mowa w pkt 4, obowiązuje po pierwszym roku działalności" & @CRLF & _
" grupy." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")