import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d";
final String string = " Art. 3.\n"
+ "1. Grupa producentów rolnych, zwana dalej \"grupą\", prowadzi działalność jako\n"
+ " przedsiębiorca mający osobowość prawną pod warunkiem, że:\n"
+ " 1) została utworzona przez producentów jednego produktu rolnego, zwanego\n"
+ " dalej \"produktem\", lub grupy produktów w celach określonych w\n"
+ " art. 2,\n"
+ " 2) działa na podstawie statutu lub umowy, zwanych dalej \"aktem\n"
+ " założyielskim\", spełniających wymagania określone w art. 4,\n"
+ " 3) składa się z członków, udziałowców lub akcjonariuszy, zwanych dalej\n"
+ " \"członkami grupy\", z których żaden nie może mieć więcej niż 20% głosów na\n"
+ " walnym zgromadzeniu lub zgromadzeniu wspólników,\n"
+ " 4) osiąga co najmniej:\n"
+ " - w pierwszym roku działalności - 51%,\n"
+ " - w drugim roku działalności - 60%,\n"
+ " - w trzecim roku i następnych latach działalności - 75%,\n"
+ " udokumentowanych przychodów ze sprzedaży produktów grupy wytworzonych w\n"
+ " gospodarstwach jej członków,\n"
+ " 5) określi obowiązujące członków grupy zasady produkcji, w tym dotyczące\n"
+ " jakości i ilości produktów lub grup produktów oraz sposoby przygotowania\n"
+ " produktów do sprzedaży.\n"
+ "2. Warunek, o którym mowa w pkt 4, obowiązuje po pierwszym roku działalności\n"
+ " grupy.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}