re = /\.(?!\d{1,3}(\.|$))/m
str = '\\\\tom.overflow.corp.com
\\\\123.43.234.23.overflow.corp.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end