import re
regex = re.compile(r"(?<latitude>[-]?[0-8]?[0-9]\.\d+|90\.0+?)(?<delimeter>.)(?<longitude>[-]?1[0-7][0-9]|[0-9]?[0-9]\.\d+|180\.0+?)")
test_str = "20.12321;80.0"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")