re = /(?<latitude>[-]?[0-8]?[0-9]\.\d+|90\.0+?)(?<delimeter>.)(?<longitude>[-]?1[0-7][0-9]|[0-9]?[0-9]\.\d+|180\.0+?)/
str = '20.12321;80.0'
# Print the match result
str.match(re) do |match|
puts match.to_s
end