$re = '/^(?=(?:.*?A){4})(?=(?:[^B]*B){2})(?=[^D]*D).+$/m';
$str = 'ABRACADABRA
BRACADABRAA
BRAACADABRAA
DBRAACADABRAA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);