re = /^(?=(?:.*?A){4})(?=(?:[^B]*B){2})(?=[^D]*D).+$/m
str = 'ABRACADABRA
BRACADABRAA
BRAACADABRAA
DBRAACADABRAA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end