#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([1-9]\d?|100)$"
Local $sString = "1" & @CRLF & _
"2" & @CRLF & _
"..." & @CRLF & _
"10" & @CRLF & _
"..." & @CRLF & _
"30" & @CRLF & _
"..." & @CRLF & _
"56" & @CRLF & _
"..." & @CRLF & _
"67" & @CRLF & _
"..." & @CRLF & _
"99" & @CRLF & _
"100" & @CRLF & _
"100" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")