#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.*<begin>)|(<end>.*)|([a-z])\3"
Local $sString = "Noot thiis <begin> buut theese need too bee chaanged <end> buut noot heeree eitheer" & @CRLF & _
""
Local $sSubst = "\1\2\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)