$re = '/(.*<begin>)|(<end>.*)|([a-z])\3/';
$str = 'Noot thiis <begin> buut theese need too bee chaanged <end> buut noot heeree eitheer
';
$subst = "\1\2\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;