use strict;
my $str = '3XMTHREADBLOCK Blocked on: java/util/Collections$SynchronizedMap@0x000000000B0D9A20 Owned by: "WebContainer : 10" (J9VMThread:0x00000000846F4900, java/lang/Thread:0x000000000B2E0A80)
3XMTHREADBLOCK Parked on: java/util/concurrent/locks/AbstractQueuedSynchronizer$ConditionObject@0x000000000296F1E8 Owned by: <unknown>
3XMTHREADBLOCK Waiting on: java/util/TaskQueue@0x0000000030A0C590 Owned by: <unowned>
';
my $regex = qr/Blocked on:[^@]*@(0x[0-9A-F]*) Owned by[^\(<]*(?:\(J9VMThread:(0x[0-9A-F]*)|<(.*)>)*|Parked on:[^@]*@(0x[0-9A-F]*) Owned by[^\(<]*(?:\(J9VMThread:(0x[0-9A-F]*)|<(.*)>)*|Waiting on:[^@]*@(0x[0-9A-F]*) Owned by[^\(<]*(?:\(J9VMThread:(0x[0-9A-F]*)|<(.*)>)*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}