re = /Blocked on:[^@]*@(0x[0-9A-F]*) Owned by[^\(<]*(?:\(J9VMThread:(0x[0-9A-F]*)|<(.*)>)*|Parked on:[^@]*@(0x[0-9A-F]*) Owned by[^\(<]*(?:\(J9VMThread:(0x[0-9A-F]*)|<(.*)>)*|Waiting on:[^@]*@(0x[0-9A-F]*) Owned by[^\(<]*(?:\(J9VMThread:(0x[0-9A-F]*)|<(.*)>)*/
str = '3XMTHREADBLOCK Blocked on: java/util/Collections$SynchronizedMap@0x000000000B0D9A20 Owned by: "WebContainer : 10" (J9VMThread:0x00000000846F4900, java/lang/Thread:0x000000000B2E0A80)
3XMTHREADBLOCK Parked on: java/util/concurrent/locks/AbstractQueuedSynchronizer$ConditionObject@0x000000000296F1E8 Owned by: <unknown>
3XMTHREADBLOCK Waiting on: java/util/TaskQueue@0x0000000030A0C590 Owned by: <unowned>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end