re = /(['"])(?:(?!\1).)*or(?:(?!\1).)*\1(*SKIP)(*F)|\bor\b/m
str = '$example or \'default value\'
"this or that"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end