#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(([^<>()\[\]\\.,;:\s@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))"
Local $sString = "johndoe@example.com" & @CRLF & _
"Name: nil" & @CRLF & _
"Email: johndoe@example.com" & @CRLF & _
"" & @CRLF & _
"John <johndoe@example.com>" & @CRLF & _
"Name: John" & @CRLF & _
"Email: johndoe@example.com" & @CRLF & _
"" & @CRLF & _
"John Doe <johndoe@example.com>" & @CRLF & _
"Name: John Doe" & @CRLF & _
"Email: johndoe@example.com" & @CRLF & _
"" & @CRLF & _
""John Doe" <johndoe@example.com>" & @CRLF & _
"Name: John Doe" & @CRLF & _
"Email: johndoe@example.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")