import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([^<>()\\[\\]\\\\.,;:\\s@\"]+(\\.[^<>()\\[\\]\\\\.,;:\\s@\"]+)*)|(\".+\"))@((\\[[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\])|(([a-zA-Z\\-0-9]+\\.)+[a-zA-Z]{2,}))";
final String string = "johndoe@example.com\n"
+ "Name: nil\n"
+ "Email: johndoe@example.com\n\n"
+ "John <johndoe@example.com>\n"
+ "Name: John\n"
+ "Email: johndoe@example.com\n\n"
+ "John Doe <johndoe@example.com>\n"
+ "Name: John Doe\n"
+ "Email: johndoe@example.com\n\n"
+ "\"John Doe\" <johndoe@example.com>\n"
+ "Name: John Doe\n"
+ "Email: johndoe@example.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}