# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.)\1\1/$1/g;t' <<< "Oh no! It seems my friends spilled beer all over my keyboard last night and my keys are super sticky now. Some of the time whennn I press a key, I get two duplicates.
Can you ppplease help me fix thhhis?"