re = /(.)\1\1/
str = 'Oh no! It seems my friends spilled beer all over my keyboard last night and my keys are super sticky now. Some of the time whennn I press a key, I get two duplicates.
Can you ppplease help me fix thhhis?'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result