$re = '/((?:0*1){3,}0*)/';
$str = '1000000010001
0001100000000
1000110010000
0000001000000
0100010000000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);