re = /((?:0*1){3,}0*)/
str = '1000000010001
0001100000000
1000110010000
0000001000000
0100010000000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end