import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bisempty\\s+\\w+";
final String string = "\"isempty var0 && v1== 56\"\n"
+ "\"v2 == 50 || isempty var1\"\n"
+ "\"Q3 == 100 || (isempty var2)\"\n"
+ "\"isempty var3\"\n"
+ "\"is thisnotisempty var4\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}