// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bisempty\s+\w+").unwrap();
let string = "\"isempty var0 && v1== 56\"
\"v2 == 50 || isempty var1\"
\"Q3 == 100 || (isempty var2)\"
\"isempty var3\"
\"is thisnotisempty var4\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}