#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!^)\/\*\! Version [^*]* \*\/"
Local $sString = "/*! Version A1 */" & @CRLF & _
"function Test1(){}/*! Testing... */" & @CRLF & _
"function Test2(){}/*! Version B1 */" & @CRLF & _
"function Test3(){}function Test4(){}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")