$re = '/(?<!^)\/\*\! Version [^*]* \*\//';
$str = '/*! Version A1 */
function Test1(){}/*! Testing... */
function Test2(){}/*! Version B1 */
function Test3(){}function Test4(){}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);