package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w*)\s*\([(\w*),]*\)`)
var str = `f1 (11,22,33)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}